Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted Oct 23, 2019 - 17:04 UTC
Investigating
We are currently experiencing increased latency on map tile services. Our team is currently investigating.
Posted Oct 23, 2019 - 16:50 UTC
This incident affected: Hosted Services (ALK Maps, PC*MILER Web) and Tools & Utilities (Content Tools).