Increased Latency on MapTiles
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 25, 2019 - 14:30 UTC
Investigating
We are currently experiencing increased latency on MapTile requests. Our team is currently investigating.
Posted 4 months ago. Feb 25, 2019 - 13:57 UTC
This incident affected: Hosted Services (ALK Maps, PC*MILER Web).