Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 17:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2021 - 17:47 UTC
Investigating
Some customers are experiencing increased latency on the routing services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Jan 06, 2021 - 17:29 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web Services - Route Matrix & Time Window Optimization Services).