Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted Oct 23, 2020 - 16:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 23, 2020 - 16:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 23, 2020 - 15:43 UTC
Investigating
Some customers are experiencing increased latency on our routing services for legacy versions of the software. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Oct 23, 2020 - 15:10 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).