Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 14:44 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 02, 2021 - 14:29 UTC
Investigating
Some customers are experiencing increased latency on the routing services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Feb 02, 2021 - 14:12 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).