Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Aug 19, 2020 - 17:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 19, 2020 - 16:36 UTC
Investigating
Some customers are experiencing increased latency on our Map Tile Services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Aug 19, 2020 - 16:13 UTC
This incident affected: Hosted Services (Trimble MAPS (formally ALK Maps), PC*MILER Web) and Tools & Utilities (Content Tools).