Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted 8 months ago. Nov 01, 2018 - 14:38 UTC
Investigating
We are noticing increased latency on our reverse geocoding and location services. Our team is currently investigating.
Posted 8 months ago. Nov 01, 2018 - 14:03 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps).