Increased Latency
Incident Report for Trimble MAPS
Resolved
We have identified the issue with our services and it has now been resolved.
Posted 7 months ago. Feb 28, 2019 - 20:51 UTC
Investigating
We are currently experiencing increased latency on our reverse geocoding and location services. Our team is currently investigating.
Posted 7 months ago. Feb 28, 2019 - 20:25 UTC
This incident affected: Hosted Services (PC*MILER Web Services).