Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted 8 months ago. Oct 31, 2018 - 20:57 UTC
Investigating
We are noticing increased latency on our reverse geocoding and map tiles. Our team is currently investigating.
Posted 8 months ago. Oct 31, 2018 - 20:40 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web).