Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted 4 months ago. May 13, 2019 - 16:40 UTC
Monitoring
The issue has been identified, a fix implemented and performance is now improving.
Our teams are continuing to monitor to assure full service recovery.
Posted 4 months ago. May 13, 2019 - 16:11 UTC
Update
We are continuing to investigate this issue.
Posted 4 months ago. May 13, 2019 - 16:08 UTC
Investigating
We are currently experiencing increased latency on our routing services.
Engineers are investigating the issue.
Posted 4 months ago. May 13, 2019 - 15:45 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).