Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 18, 2019 - 21:20 UTC
Investigating
We are currently experiencing increased latency on our reverse geocoding and location services. Our team is currently investigating.
Posted 3 months ago. Mar 18, 2019 - 20:20 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web).