Increased Latency
Incident Report for Trimble MAPS
Resolved
All services have returned to normal operating status.

If you are encountering any issues, please do not hesitate to reach out to PCMsupport@alk.com for assistance. For additional resources, please also see support.alk.com.
Posted Mar 23, 2019 - 17:12 UTC
Update
Service latency levels remain reduced and stable.
Engineers are continuing to execute a plan to fully restore service.
Posted Mar 23, 2019 - 08:39 UTC
Update
At this time service latency levels remain reduced and stable. Traffic continues to be handled by multiple redundant servers as a contingency. Engineers are currently executing a plan to fully restore service.
Posted Mar 23, 2019 - 00:54 UTC
Update
Service latency levels remain reduced and stable but above normal operating levels. Traffic continues to be handled by multiple redundant servers as a contingency. Engineers are currently executing a plan to fully restore service.
Posted Mar 22, 2019 - 16:56 UTC
Identified
Service latency levels remain reduced and stable but above normal operating levels. Traffic continues to be handled by multiple redundant servers as a contingency. Engineers are currently executing a plan to fully restore service.
Posted Mar 22, 2019 - 13:40 UTC
Update
Our engineers continue to investigate periods of latency on the service.
As a contingency traffic is currently being shared across multiple redundant servers to minimise the impact on production.
Posted Mar 22, 2019 - 09:21 UTC
Update
Our engineers are continuing to investigate the service latency as a matter of urgency.
Posted Mar 22, 2019 - 06:40 UTC
Update
We are currently experiencing increased latency on our services. Our team is investigating.
Posted Mar 22, 2019 - 04:00 UTC
Investigating
We are currently experiencing increased latency on our services. Our team is investigating.
Posted Mar 22, 2019 - 00:54 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web) and Tools & Utilities (Content Tools).