Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Oct 01, 2019 - 20:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2019 - 19:18 UTC
Investigating
We are currently experiencing increased latency on our services. Our team is currently investigating.
Posted Oct 01, 2019 - 18:55 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web) and Tools & Utilities (Content Tools).