Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted Oct 15, 2020 - 17:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 15, 2020 - 17:40 UTC
Investigating
Some customers are experiencing increased latency on our routing and geocoding services for worldwide data. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Oct 15, 2020 - 17:38 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web Services - Route Matrix & Time Window Optimization Services).