Traffic Service Outage
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 12:55 UTC
Update
Live Traffic for CoPilot, PC*MILER On-Prem, PC*MILER Web Services & Maps has been restored.

Our North America Traffic Data Provider continues to experience a disruption in service on the traffic tile layer for hosted Maps. The supplier's Engineers have identified an issue and are working to deploy a fix.
Posted Apr 03, 2020 - 20:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 02, 2020 - 14:55 UTC
Update
Our North America Traffic Data Provider continues to experience a disruption in service. The supplier's Engineers have identified an issue and are working to deploy a fix.
Posted Apr 01, 2020 - 12:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 31, 2020 - 12:47 UTC
Update
Our North America Traffic Data Provider continues to experience a disruption in service. Due to this, some customers are experiencing increased latency on our Routing Services when utilizing live traffic. The supplier's Engineers have identified an issue and are working to deploy a fix.

If you require immediate assistance, please contact our Support Team.
Posted Mar 30, 2020 - 16:03 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 28, 2020 - 23:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 28, 2020 - 20:01 UTC
Identified
Our North America Traffic Data Provider is experiencing a disruption in service. The supplier's Engineers have identified an issue and are working to deploy a fix. If you require immediate assistance, please contact our Support Team.
Posted Mar 28, 2020 - 19:59 UTC
This incident affected: Traffic Services (CoPilot Traffic, PC*MILER (On Premise) Traffic Service) and Hosted Services (Trimble MAPS (formally ALK Maps)).