Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted 9 months ago. Sep 24, 2018 - 20:35 UTC
Investigating
We are noticing increased latency on our geocoding and location services. Our team is currently investigating.
Posted 9 months ago. Sep 24, 2018 - 20:25 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web).