Increased Latency
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Nov 13, 2020 - 14:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2020 - 14:55 UTC
Investigating
Some customers are experiencing increased latency on the Routing Services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Nov 13, 2020 - 14:38 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).