Increased Latency on Satellite Imagery
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Aug 28, 2020 - 19:50 UTC
Investigating
Some customers are experiencing increased latency on our satellite imagery services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Aug 28, 2020 - 17:47 UTC
This incident affected: Hosted Services (Trimble MAPS (formally ALK Maps), PC*MILER Web) and Tools & Utilities (Content Tools).