PC*MILER Web - Degraded Performance
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted May 15, 2020 - 15:11 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted May 15, 2020 - 14:46 UTC
Investigating
Some customers are experiencing increased latency and intermittent errors on PC*MILER Web UI. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted May 15, 2020 - 14:01 UTC
This incident affected: Hosted Services (PC*MILER Web).