Increased Latency
Incident Report for ALK Technologies
Resolved
This incident has been resolved.
Posted 16 days ago. Apr 05, 2019 - 21:40 UTC
Monitoring
Latency has decreased significantly. Our teams continue to monitor the situation.
Posted 16 days ago. Apr 05, 2019 - 21:14 UTC
Investigating
We are currently experiencing increased latency on our reverse geocoding and location services. Our team is currently investigating.
Posted 16 days ago. Apr 05, 2019 - 21:06 UTC
This incident affected: Hosted Services (PC*MILER Web Services).