Increased Latency
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Sep 23, 2020 - 21:22 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted Sep 23, 2020 - 21:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 23, 2020 - 20:02 UTC
Investigating
Some customers are experiencing increased latency on map tile services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Sep 23, 2020 - 19:23 UTC
This incident affected: Hosted Services (Trimble MAPS (formally ALK Maps), PC*MILER Web) and Tools & Utilities (Content Tools).