Increased Latency
Incident Report for Trimble MAPS
Resolved
The incident has been resolved.
Posted Apr 18, 2019 - 20:12 UTC
Monitoring
Performance is improving and returning to normal. Our teams are continuing to monitor.
Posted Apr 18, 2019 - 19:34 UTC
Investigating
We are currently experiencing increased latency on our routing services. Our team is continuing to investigate.
Posted Apr 18, 2019 - 18:12 UTC
Monitoring
Performance is improving and returning to normal. Our teams are continuing to monitor.
Posted Apr 18, 2019 - 16:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2019 - 16:39 UTC
Investigating
We are currently experiencing increased latency on our routing services.
Posted Apr 18, 2019 - 15:14 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).