Traffic Service Outage
Incident Report for Trimble MAPS
Resolved
Traffic for CoPilot, PC*MILER On-Prem, PC*MILER Web Services & Maps has been restored. This incident has been resolved.
Posted Jun 19, 2020 - 17:07 UTC
Investigating
Our North America Traffic Data Provider is experiencing a disruption in service. The supplier's Engineers are investigating this issue. If you require immediate assistance, please contact our Support Team.
Posted Jun 19, 2020 - 15:49 UTC
This incident affected: Hosted Services (PC*MILER Web Services, Trimble MAPS (formally ALK Maps)) and Traffic Services (CoPilot Traffic, PC*MILER (On Premise) Traffic Service).