Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted Oct 26, 2020 - 14:18 UTC
Investigating
Some customers are experiencing increased latency on our routing services. We are actively investigating the issue and apologize for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Oct 26, 2020 - 13:48 UTC
This incident affected: Hosted Services (PC*MILER Web Services, PC*MILER Web).