Increased Latency
Incident Report for Trimble MAPS
Resolved
This incident has been resolved.
Posted 5 days ago. Sep 11, 2019 - 17:58 UTC
Monitoring
Our performance is improving and returning to normal. Our teams are continuing to monitor.
Posted 5 days ago. Sep 11, 2019 - 17:43 UTC
Investigating
We are currently experiencing increased latency on the reverse geocoding and location services.
Our team is currently investigating.
Posted 5 days ago. Sep 11, 2019 - 17:03 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web) and Tools & Utilities (Content Tools).