Increased Latency
Incident Report for Trimble MAPS
Resolved
The issue has been identified and a fix has been implemented. This incident is now resolved.
Posted Apr 15, 2019 - 13:01 UTC
Investigating
We are currently experiencing increased latency on the reverse geocoding and location services.
Our team is currently investigating
Posted Apr 15, 2019 - 12:19 UTC
This incident affected: Hosted Services (PC*MILER Web Services).