Increased Latency
Incident Report for Trimble MAPS
Resolved
Full service has been restored and a period of stability observed. The incident has been resolved.
Posted Oct 02, 2019 - 13:06 UTC
Monitoring
A fix has been deployed. Services are now being monitored to confirm a return to normal operation.
Posted Oct 02, 2019 - 12:32 UTC
Update
We are continuing to investigate this issue.
Posted Oct 02, 2019 - 12:27 UTC
Investigating
Some customers are experiencing increased latency on the Services. We are actively investigating the issue and apologise for any inconvenience. Further updates will be sent as engineers identify and resolve the issue. If you require immediate assistance, please contact our Support Team.
Posted Oct 02, 2019 - 11:21 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web) and Tools & Utilities (Content Tools).