Increased Latency
Incident Report for ALK Technologies
Resolved
This incident has been resolved.
Posted 20 days ago. Apr 01, 2019 - 21:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 20 days ago. Apr 01, 2019 - 20:55 UTC
Investigating
We are currently experiencing increased latency on our reverse geocoding and location services. Our team is currently investigating.
Posted 20 days ago. Apr 01, 2019 - 20:27 UTC
This incident affected: Hosted Services (PC*MILER Web Services, ALK Maps, PC*MILER Web).